應該算是 dpkg 相關的問題吧..^^"

發表回覆

確認代碼 (前四碼)
請正確輸入它所顯示的代碼 (前四碼),不必區分大小寫。
表情符號
:-D :-) :-( :-o :-? 8-) :-x :-P ;-) :ooops: :crying: :mygod: :mrgreen: :sleep1: :finger1: :D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :kuso_1.01: :kuso_1.02: :kuso_1.04: :kuso_1.05: :kuso_1.06:
顯示更多表情符號
BBCode 允許使用
[img] 允許使用
[flash] 禁止使用
[url] 允許使用
表情符號 允許使用
主題瀏覽
   

展開瀏覽 主題瀏覽: 應該算是 dpkg 相關的問題吧..^^"

文章訪客 » 週四 4月 13, 2006 2:07 am

我將此 script 放在 /etc/rc.daily
#bin/bash
apt-get update
apt-get -y dist-upgrade
apt-get clean

而紀錄檔都會出現:
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
Couldn't reopen stdin at /usr/sbin/update-inetd line 34.
dpkg: error processing samba (--configure):
subprocess post-installation script returned error exit status 6
Setting up belocs-locales-bin (2.3.5-5ubuntu5) ...
Setting up module-init-tools (3.2.2-1ubuntu6) ...

Setting up dselect (1.13.11ubuntu5) ...
Setting up libpq4 (8.1.3-4) ...

Errors were encountered while processing:
postfix
samba
E: Sub-process /usr/bin/dpkg returned an error code (1)


但只要在 console 下指令:
apt-get install debconf
就可以 restart postfix & samba, 放在 /etc/daily 就不行!?
(有安裝 dialog & whiptail)

re:應該算是 dpkg 相關的問題吧..^^"

文章slog » 週一 12月 06, 2004 2:17 pm

嗯..謝謝你..
我記得我是貼在 misc 版說..@@"
那是不是能請版主或站長幫我移個版面呢? ^^"

--
新手上路, 實在很對不起..

re:應該算是 dpkg 相關的問題吧..^^"

文章d2207197 » 週日 12月 05, 2004 6:44 pm

應該是缺少 dialog-like 程式
apt-get install dialog 或 apt-get install whiptail

--
另外, debian command 這個版不是拿來問問題的喔

應該算是 dpkg 相關的問題吧..^^"

文章slog » 週五 12月 03, 2004 1:21 am

我用 apt-get upgrade 之後, 有幾個 package 要 upgrade..
然後就抓回來安裝, 會出現這樣的 msg ,

我遇到好幾次了..
請各位前輩懇請賜教..
-------------------------------------------------------------
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog
based fronte
nd cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line
66, <line 4.)
debconf: falling back to frontend: Readline
Selecting previously deselected package libattr1.
-------------------------------------------------------------

--
* Origin: http://moto.debian.org.tw/

回頂端

cron