[分享]阿信版的woody backport packages

如果您覺得您的問題不屬於 debian desktop 或是 debian server 版的範圍內,請在這裡發問。

版主: mufa

[分享]阿信版的woody backport packages

文章阿信 » 週一 5月 26, 2003 10:18 am

昨天弄了一整天的mozilla和xine。

我將mozilla取消了gtk2,xft的編譯,因為woody並沒有該library,但是xcin是正常可以使用overthespot。

而xine的部份比較難修改,因為要牽涉到debhelper的功能,所以用別的方式hack,目前測試是ok了。

在使用小弟的backport之前,請先修改一下自己的sources.list,加入一些敘述。

# backport mplayer or some multimedia package
deb http://marillat.free.fr/ stable main

#vlc
deb http://www.videolan.org/pub/videolan/debian i386/

# for kde 3.1.2
deb http://download.kde.org/stable/3.1.2/Debian stable main

這是我編譯會用到的package,所有的dependency都可以解決。

然後請加入以下的list

# asho backport
deb http://freenix.iis.sinica.edu.tw/~moto woody/

然後打apt-get update,就可以用apt-get安裝了。

有任何的問題請寫信給我吧。
:-)

另外也徵求各位的意見,需要那些backport,小弟有能力就幫忙製作。

目前的TODO:

kile-1.5,k3b,TETEX
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章阿信 » 週一 5月 26, 2003 11:25 am

kile is done...

apt-get update to install kile

:-)
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章moto » 週一 5月 26, 2003 11:26 am

讚讚讚 !!! 感謝 阿信的努力.. Mozilla 1.3.1 + gtk1 重新編譯後..現在也支援 over the spot mode 的輸入..Ya ... 太讚了... :finger1:

另外我也新增了兩個 package ,我另外獨立一篇 post 好了,免得大家搞混了..:-P

ps.to 阿信:你原來的 Packages.gz 裡頭的路徑有錯 ,我已經修正..通知你一聲..

;-)
歡迎你來到MOTO學園一起討論Debian相關問題。
在post問題前可先別忘記了以下的步驟:
1:翻一下/usr/share/doc/中是否已經有解答了?
2:閱讀一下無痛起步是否已經提到了?
3:找一下google予以解答?
4:善用學園中的"搜尋"功能,往往答案就在裡面窩。
頭像
moto
摩托學園站長
摩托學園站長
 
文章: 2808
註冊時間: 週二 9月 03, 2002 3:37 am
來自: 台北

文章阿信 » 週一 5月 26, 2003 11:40 am

moto 寫:讚讚讚 !!! 感謝 阿信的努力.. Mozilla 1.3.1 + gtk1 重新編譯後..現在也支援 over the spot mode 的輸入..Ya ... 太讚了... :finger1:

另外我也新增了兩個 package ,我另外獨立一篇 post 好了,免得大家搞混了..:-P

ps.to 阿信:你原來的 Packages.gz 裡頭的路徑有錯 ,我已經修正..通知你一聲..

;-)


:shock: ...真的耶,感謝老哥幫忙,現在已經將問題修正了,後來的kile的路徑問題已經修正好了。
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章訪客 » 週二 5月 27, 2003 6:35 pm

請問…可以麻煩幫忙製作 qterm 0.2.0 的 backport 嗎?謝謝。 :-)
訪客
 

文章阿信 » 週二 5月 27, 2003 6:45 pm

Anonymous 寫:請問…可以麻煩幫忙製作 qterm 0.2.0 的 backport 嗎?謝謝。 :-)


ok...我作backport的時間都是晚上10:00以後,如果有需要什麼package的話,可以在此thread點名。
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章阿信 » 週二 5月 27, 2003 8:19 pm

Anonymous 寫:請問…可以麻煩幫忙製作 qterm 0.2.0 的 backport 嗎?謝謝。 :-)


qterm 0.2.0 is done

just update you apt after 10:00pm

apt-get install qterm...

any comment? just send e-mail for me...
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章yuanfarn » 週三 5月 28, 2003 2:40 pm

qterm 0.2.0 真是好用呢!

可以再麻煩幫忙製作 OpenOffice.org
和 for KDE3.x 的 Kmerlin 嗎?
謝謝! :-)

ps. 我從 apt-get.org 試過的三個 OpenOffice.org 都不能正確表現粗體和楷體,unstable 裡記得是可以的啊!
目前使用率較高的就這幾個軟體,再一次麻煩您了。
*萬分感謝貌* :-)
yuanfarn
懵懂的國中生
懵懂的國中生
 
文章: 102
註冊時間: 週一 10月 28, 2002 2:45 am
來自: 彰化縣

文章阿信 » 週三 5月 28, 2003 3:21 pm

:-o ...OpenOffice...這...可能要久一點了窩,因為OpenOffice編譯滿久的

不知道我的P4 2.4G + 1G雙通道的記憶體要不要花6小時呢。

我想先製作kmerlin,然後過幾天再來弄openoffice...

只好請yuanfarn兄等等了... :-(
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章阿信 » 週三 5月 28, 2003 4:49 pm

:crying: ...kmerlin似乎有程式上得錯誤,編譯不起來,也沒有官方網站可以看... :crying: :crying:
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章yuanfarn » 週三 5月 28, 2003 11:10 pm

辛苦您了。

對了,那可以幫忙製作 gaim 的 backport 嗎?
謝謝。 :-)

ps. 有點小可惜,Kmerlin 在 KDE 3.x 下可以像 Windows 的 MSN Messenger 一樣收在工作列裡成一個小小的 ICON 呢! :-P
yuanfarn
懵懂的國中生
懵懂的國中生
 
文章: 102
註冊時間: 週一 10月 28, 2002 2:45 am
來自: 彰化縣

文章阿信 » 週三 5月 28, 2003 11:15 pm

yuanfarn 寫:辛苦您了。

對了,那可以幫忙製作 gaim 的 backport 嗎?
謝謝。 :-)

ps. 有點小可惜,Kmerlin 在 KDE 3.x 下可以像 Windows 的 MSN Messenger 一樣收在工作列裡成一個小小的 ICON 呢! :-P


嗯...woody的確沒有收錄gaim。

但是gaim新版本似乎是採用gtk2的版本,而我不太想port gtk2到stable,不知道yuanfarn兄是需要gaim來傳msn嗎?

不然我只能port gaim for gtk1到stable呢。

至於kmerlin我會繼續trace,因為qt在stable還滿穩定的。
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章阿信 » 週三 5月 28, 2003 11:17 pm

另外...補充一下,小弟有upload kernel-image-2.4.18-asho-686和kernel-image-2.4.18-asho-k7

這個版本的kernel-image有支援xfs,preempt以及high memory到4G,且小弟測試滿久了,應該算穩定,可以抓回來使用。
頭像
阿信
版面大總管
版面大總管
 
文章: 4756
註冊時間: 週二 9月 03, 2002 11:58 pm
來自: 台灣 - 嘉義

文章yuanfarn » 週四 5月 29, 2003 2:21 am

阿信 寫:嗯...woody的確沒有收錄gaim。

但是gaim新版本似乎是採用gtk2的版本,而我不太想port gtk2到stable,不知道yuanfarn兄是需要gaim來傳msn嗎?

不然我只能port gaim for gtk1到stable呢。

至於kmerlin我會繼續trace,因為qt在stable還滿穩定的。


是的,我也是 MSN 的一個使用者。
:-P
yuanfarn
懵懂的國中生
懵懂的國中生
 
文章: 102
註冊時間: 週一 10月 28, 2002 2:45 am
來自: 彰化縣

文章高原之狼 » 週四 5月 29, 2003 6:37 am

Woody 怎麽可能沒有 gaim 呢,這是多麽老資格的 GNOME software 啊。只不過版本比較老就是了(0.58)。

而且 gaim 是不需要 GTK 2 的,GTK 2 的好處也就是提供了 Antialias 而已。gaim 確實也只依賴 libgtk1.2。

據 gaim 的 Debian maintainer 說,所有的 gaim package in sid 都應該能直接拿到 woody 下面來編譯。他前幾天剛做好了一個 package,在這裡:
http://people.debian.org/~robot101/gaim-woody/gaim_0.63-1.0woody1_i386.deb
這裡沒有 Packages.gz,所以不能直接 apt-get,不過阿信兄你是不是可以考慮把它放在你們的 backport archive 裏面呢?

如果有興趣的話,可以去看 Debian maillist: http://lists.debian.org/debian-gtk-gnome/2003/debian-gtk-gnome-200305/msg00178.html

最後要說的一句就是:woody 是有 GTK 2 的,apt-cache search libgtk2.0 就知道啦。
高原之狼
懵懂的國中生
懵懂的國中生
 
文章: 185
註冊時間: 週一 10月 28, 2002 5:54 am

下一頁

回到 debian misc

誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客

cron